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Video Editing Pro User Manual 
Chapter 1: Introduction to Video Editing Pro 
Video Editing Pro is a powerful video editing software designed for both beginners and 
experienced video editors. It provides a wide range of tools and features that allow users to 
create professional-quality videos. This chapter covers the basic introduction to Video Editing 
Pro, its system requirements, and installation process. 

 

1.1 What is Video Editing Pro? 

Key Features of Video Editing Pro: 

 Wide format support: Video Editing Pro supports hundreds of video and audio 
formats. 

 Non-linear editing (NLE): Allows users to edit multiple tracks and timelines. 
 Video and audio effects: Offers numerous filters and effects for both video and 

audio. 
 Resolution and Frame Rate Flexibility: Edit videos from 360p to 4K resolution, 

supporting a variety of frame rates. 
 Customizable Interface: You can arrange the interface according to your preferences. 

Video Editing Pro is designed to cater to various video editing needs, from simple cuts to 
advanced tasks such as color grading and multi-track audio mixing. 

 

1.2 System Requirements 

Before installing Video Editing Pro, make sure your system meets the minimum 
requirements. This will ensure smooth operation and prevent crashes or lag while editing. 

Minimum System Requirements: 

 Operating System: 
o Windows: Windows 8, 10 or 11 (64-bit) 

 CPU: 
o Multi-core processor (Intel Core i3 or equivalent, 2 GHz or faster) 

 RAM: 
o 4 GB or more (8 GB or more recommended for 4K video editing) 

 Graphics: 
o Dedicated GPU with OpenGL 2.0 support (recommended for better 

performance) 
 Storage: 

o 500 MB of free disk space for installation 
o 5 GB or more free space for video editing projects 



Recommended System Requirements: 

 Operating System: 
o Windows: Windows 10, 11 (64-bit) 

 CPU: 
o Intel Core i5 or equivalent, 3 GHz or faster 

 RAM: 
o 8 GB or more 

 Graphics: 
o Dedicated GPU with at least 2 GB VRAM (NVIDIA or AMD recommended) 

 Storage: 
o SSD with at least 100 GB of free space 

These recommended specifications will help you work with HD or 4K videos with smoother 
playback and faster rendering times. 

 

1.3 Installation 

Installing Video Editing Pro is a straightforward process. Below are the steps for installing 
Video Editing Pro on various operating systems. 

Windows Installation: 

1. Download the Installer 
2. Run the Installer: 

o After the download is complete, double-click the .exe file to launch the 
installer. 

o Follow the on-screen instructions to install Video Editing Pro on your system. 
o You can choose the default installation path or change it according to your 

preferences. 
3. Complete Installation: 

o Once the installation is complete, click Finish to exit the installer. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 



 

Chapter 2: User Interface 
Video Editing Pro’s interface is designed for simplicity and flexibility, making it easy for both 
beginners and experienced users to navigate. In this chapter, we will explore the main 
window, menu bar, toolbars, and various panels. 

 

2.1 Main Window 

The main window of Video Editing Pro is the core workspace where you will do most of your 
editing. It is divided into several areas, each serving a specific purpose: 

 Timeline: The timeline is where you arrange and edit clips, add transitions, and 
manage your video and audio tracks. 

 Preview Window: Displays the current frame or segment of your video, allowing you 
to preview your edits. 

 Playlist: A panel where all imported media files are shown. It helps you quickly 
access clips, audio, and images you want to use in your project. 

 Filters Panel: This is where you can apply and manage video and audio filters. 
 Properties Panel: Shows the properties of selected clips, such as duration, resolution, 

and aspect ratio. 

2.2 Menu Bar 

The menu bar provides access to various functions and settings in Video Editing Pro. The 
main menus include: 

 File: This menu includes options for creating a new project, opening, saving, and 
exporting projects. 

 Edit: Offers basic editing functions like undo, redo, cut, copy, paste, and preferences. 
 View: Allows you to toggle visibility for various panels, including the timeline, 

playlist, and filters. 
 Playback: Provides playback control options such as play, pause, rewind, and fast 

forward. 
 Tools: Contains tools for advanced features like color grading and video stabilization. 

2.3 Toolbars 

Video Editing Pro has several toolbars that make it easy to access common editing functions: 

 Main Toolbar: Located at the top of the window, it includes basic tools like the play 
button, pause, undo, redo, and file management options. 

 Timeline Toolbar: Provides quick access to timeline-related actions such as adding 
new tracks, zooming in/out, and setting the snap feature. 

 Playback Controls: Located below the preview window, these controls allow you to 
play, pause, and scrub through the video timeline. 



2.4 Windows and Panels 

Video Editing Pro’s interface is highly customizable, allowing you to arrange various panels 
and windows according to your needs. Some useful panels include: 

 Timeline Panel: The timeline is used to arrange, cut, trim, and manage your clips. 
 Playlist Panel: Displays imported clips and audio files for easy access. 
 Filters Panel: Where you can add and customize video and audio filters. 
 Properties Panel: Shows the properties and settings of the selected clip. 

Each panel is resizable and can be docked or floated, depending on your preferences. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



 

Chapter 3: Project Management 
Effective project management in Video Editing Pro is key to keeping your editing workflow 
smooth and organized. This chapter covers how to create a new project, open or save an 
existing project, and import media files. 

 

3.1 Creating a New Project 

Starting a new project in Video Editing Pro is easy and customizable. Here’s how you can 
create a new project: 

1. Launch Video Editing Pro: Open the Video Editing Pro software.  
2. Create New Project: 

o Go to the File menu at the top of the screen and select New Project. 
o A dialog box will appear prompting you to select your Project Folder and 

Project Name. 
 Project Folder: This is the location where all your project files (media, 

saved projects, etc.) will be stored. It's a good idea to keep everything 
in one dedicated folder. 

 Project Name: Enter a unique name for your project. 
o Video Mode: Video Editing Pro will prompt you to choose a video mode, 

which includes settings like resolution (HD, 4K, etc.) and frame rate (24, 30, 
60 FPS). You can change this setting later in the project settings if necessary. 

o Audio Mode: You can also set the audio sample rate, but for most users, the 
default setting is fine. 

3. Click Start: 
o Once you’ve selected your project folder, video mode, and name, click Start. 
o Video Editing Pro will open a new workspace where you can start adding 

media and editing your project. 

 

 

 

 

 

 

 

 



 

3.2 Opening and Saving a Project 

Video Editing Pro allows you to open and save projects to continue working on them at a later 
time. Here's how: 

Opening an Existing Project: 

1. File Menu: Click File in the menu bar and select Open Project. 
2. Browse: Navigate to the location where your project file is stored (usually a .mlt file) 

and select it. 
3. Open: Video Editing Pro will load the project with all media files, timeline settings, 

and effects you’ve previously set. 

Saving Your Project: 

 To save your project, go to File and click Save Project. This will save all changes 
made to the project in its current state. 

 If you are working on a new project for the first time, Video Editing Pro will prompt 
you to choose a location and name for the project file. 

Save As (for a New Version): 

1. If you wish to save a new version of your project or store it in a different location, 
click File > Save Project As. 

2. Choose a new name or location, and Video Editing Pro will save a copy of the current 
project under that name. 

 

 

 

 

 

 

 

 

 

 

 



 

3.3 Importing Media 

Importing media (videos, images, and audio files) into Video Editing Pro is simple. Here's 
how to get started: 

1. Open Playlist: The Playlist panel in Video Editing Pro is where your media files will 
appear once imported. If it’s not visible, go to View in the menu bar and select 
Playlist to open it. 

2. Import Media: 
o There are multiple ways to import media: 

 Drag and Drop: Simply drag your media files (video, audio, or image 
files) from your file explorer and drop them into the Playlist panel. 

 Menu Import: Go to File > Open File and navigate to the location of 
your media files. Select the files you wish to import. 

3. Browse Files: Video Editing Pro supports many media formats, so you can import a 
wide range of file types, including .mp4, .mov, .avi, .mp3, and many others. Just 
ensure your files are in a compatible format. 

4. Viewing Media: 
o Once the files are imported into the Playlist, you can drag them directly onto 

the timeline or use them in the preview window to inspect their content before 
placing them on the timeline. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



 

Chapter 4: Working with the Timeline 
The Timeline is where you will do the majority of your editing in Video Editing Pro. It’s a 
crucial component of the video editing workflow, allowing you to arrange clips, cut and trim 
content, and add transitions. In this chapter, we'll cover how to add clips, cut and trim them, 
and create smooth transitions. 

 

4.1 Adding Clips to the Timeline 

The Timeline is where the magic happens. Once your media files are imported into the 
Playlist, you can easily add them to the timeline. Here’s how: 

1. Open the Timeline Panel: If the timeline panel is not visible, go to View in the top 
menu and select Timeline. 

2. Add Clips: 
o To add clips from your Playlist to the Timeline, simply drag and drop them. 
o Video Editing Pro supports multiple tracks. You can drag media files to any 

video or audio track on the timeline. 
o As you drag the clip onto the timeline, you will see a preview of the clip’s 

duration and placement. Release the mouse button to drop it onto the timeline. 
3. Timeline Tracks: 

o Video Tracks: These are represented as horizontal bands for each video clip. 
You can have multiple video tracks for complex compositions. 

o Audio Tracks: Audio tracks are similar to video tracks but for sound. You can 
add multiple audio tracks for different audio layers (dialogue, background 
music, sound effects). 

o Track Header: Each track has a header with an eye icon to toggle visibility, 
and a lock icon to lock the track so that no further changes can be made to it. 

4. Adjust Clip Position: To move a clip on the timeline, click on it, drag it left or right, 
and drop it in the new position. 

 

 

 

 

 

 

 

 



 

4.2 Cutting and Trimming Clips 

Editing video clips involves cutting or trimming them to fit your timeline. Video Editing Pro 
provides simple tools for these operations. 

Trimming Clips: 

1. Select the Clip: Click on the clip in the timeline that you wish to trim. 
2. Trim Using Handles: 

o Hover over the beginning or end of the clip. You will see a red Trim Handle 
appear. 

o Drag the trim handle to the left to shorten the clip from the start, or to the right 
to trim it from the end. 

3. Preview: After trimming, preview the clip in the Preview Window to ensure it’s 
trimmed correctly. 

Cutting Clips: 

1. Select the Clip: Click on the clip you want to cut. 
2. Set the Playhead: Move the Playhead (the vertical line that shows the current 

position of your video) to the point where you want to cut. 
3. Cut the Clip: 

o Right-click on the clip and select Split at Playhead, or use the shortcut S to 
split the clip at the playhead. 

o The clip will be cut into two parts at the position of the playhead. You can now 
move, delete, or adjust each part individually. 

4. Deleting Portions: 
o To delete a portion of the clip, select it and press the Delete key, or right-click 

and choose Remove. 

 

 

 

 

 

 

 

 

 

 



 

4.3 Overlapping Clips and Creating Transitions 

Creating transitions between clips helps your video flow smoothly. In Video Editing Pro, you 
can overlap clips to create transitions. Here’s how to do it: 

Overlapping Clips: 

1. Drag and Overlap Clips: To create a transition, simply drag a clip on top of the clip 
that precedes it. The clips will overlap on the timeline, and Video Editing Pro will 
automatically create a transition. 

2. Adjust the Overlap: The longer the overlap, the longer the transition effect will last. 
You can adjust the duration by clicking and dragging the edge of the overlapping clip. 

3. Edit the Transition: 
o Click on the overlapping area (the transition zone) on the timeline. A transition 

bar will appear. 
o Right-click on the transition bar to adjust the transition type (e.g., Dissolve, 

Wipe, etc.) or change its duration. 

Transition Effects: 

 Dissolve: The default transition in Video Editing Pro is a simple dissolve between 
clips, where one clip fades into the next. 

 Wipe and Slide: Other transitions like wipe or slide can be applied by changing the 
transition properties in the Properties Panel. 

 

 

 

 

 

 

 

 

 

 

 

 



 

Chapter 5: Effects and Filters 
In Video Editing Pro, video and audio effects play a crucial role in enhancing your project. 
Whether you are color grading your video, adding sound effects, or applying stylistic 
adjustments, the Effects and Filters allow you to modify and refine your clips. In this chapter, 
we will explore the available video and audio effects, how to apply filters, and how to adjust 
effects to achieve the desired results. 

 

5.1 Video and Audio Effects 

Video Editing Pro provides a range of video and audio effects that can be applied to clips in 
your project. These effects can adjust the visual appearance and audio quality, helping you 
create professional-grade videos. 

Video Effects: 

Video effects in Video Editing Pro can be used to enhance the look of your footage, correct 
colors, add visual effects, or even create cinematic transitions. 

1. Applying Video Effects: 
o Select the video clip you want to apply the effect to in the timeline. 
o Go to the Filters Panel (If not visible, open it by going to View > Filters). 
o Click the + button to add a new filter. 
o A list of available filters will appear. You can choose from categories like 

Color, Crop, Sharpen, Blurs, and more. 
2. Common Video Effects: 

o Color Grading: Adjust the color balance, saturation, brightness, contrast, and 
gamma of your video to give it a professional look. 

o Crop: Crop the video to remove unwanted areas from the frame. 
o Blur: Apply a Gaussian blur, motion blur, or box blur for aesthetic or focus-

shifting purposes. 
o Chroma Key (Green Screen): Remove a specific color (usually green or blue) 

from the video, which is useful for keying effects. 
o Transform: Adjust the position, size, rotation, and scaling of the video. 

3. Video Transitions: 
o Video Editing Pro allows you to create transitions between clips by 

overlapping them on the timeline. By adding video effects to the transition 
area, you can adjust how the transition will look. 

 

 

 

 



Audio Effects: 

Audio effects in Video Editing Pro are used to improve the sound quality or create specific 
sound effects. They are essential for tasks like noise reduction, equalization, and audio 
enhancement. 

1. Applying Audio Effects: 
o Select the audio clip in the timeline. 
o Go to the Filters Panel and click the + button. 
o A list of audio effects will appear, including Volume, Equalizer, 

Compressor, and more. 
2. Common Audio Effects: 

o Gain/Volume: Adjust the volume of the audio track. 
o Equalizer: Adjust the frequency ranges of the audio, allowing you to boost or 

cut bass, midrange, or treble frequencies. 
o Compressor: Compress the dynamic range of your audio to ensure consistent 

volume levels. 
o Reverb: Add a sense of space or atmosphere to your audio, simulating the 

sound of different environments. 

 

5.2 Applying Filters 

Filters in Video Editing Pro are essential tools to change the appearance of your video and 
modify its characteristics. They can be applied to both video and audio clips. 

Applying Video Filters: 

1. Select Your Clip: First, select the video clip you wish to edit on the timeline. 
2. Open the Filters Panel: Go to View > Filters if the Filters panel is not already 

visible. 
3. Add a Filter: 

o Click the + icon in the Filters panel. 
o Browse through the list of available video filters. 
o Select the desired filter and it will be applied to your video. 

4. Adjusting the Filter: 
o After adding a filter, you can adjust its parameters by using the sliders or input 

fields provided in the Properties Panel for that filter. 
o For example, if you add a Color Grading filter, you can adjust Brightness, 

Saturation, and other settings to fine-tune the visual effect. 

 

 

 

 

 



Applying Audio Filters: 

1. Select Audio Clip: Choose the audio track you want to apply a filter to in the timeline. 
2. Add an Audio Filter: 

o Click the + button in the Filters panel. 
o Browse for audio-specific filters like Compressor, Noise Gate, and 

Equalizer. 
o Apply the selected filter to adjust the audio output. 

3. Adjusting Audio Filters: 
o After applying an audio filter, you can tweak the effect’s settings through the 

Properties Panel. For example, with the Compressor, you can adjust 
threshold, ratio, attack, and release. 

Removing Filters: 

 If you want to remove a filter, select it in the Filters Panel, and click the Delete 
button (trash can icon). 

 Filters can be layered and stacked, but removing unwanted filters helps keep your 
project clean and organized. 

 

5.3 Adjusting Effects 

Once effects and filters are applied, you may need to fine-tune them to get the desired result. 
Video Editing Pro provides an intuitive interface for adjusting the parameters of both video 
and audio effects. 

Adjusting Video Effects: 

1. Selecting the Effect: To adjust a video effect, click on the filter name in the Filters 
Panel. The properties of the effect will appear in the Properties Panel. 

2. Using Sliders and Input Fields: 
o For many effects (e.g., Color Grading), Video Editing Pro provides sliders for 

key parameters such as Brightness, Contrast, Saturation, and more. 
o You can also enter values manually for precise control over the adjustments. 

3. Previewing Adjustments: 
o After adjusting the effect, you can preview it by playing the video in the 

Preview Window. This will allow you to see how the effect interacts with the 
rest of your project. 

4. Fine-Tuning Effects: 
o For effects such as Blur or Transform, Video Editing Pro provides input 

boxes for values like Radius or Rotation, which can be adjusted numerically. 
o Some effects also allow you to animate parameters over time, which is useful 

for adding motion or dynamic changes to your video. 

 

 

 



Adjusting Audio Effects: 

1. Audio Filters: Click on the audio filter in the Filters Panel to display its settings. 
2. Using Sliders: 

o For effects like Gain/Volume, you can use a slider to increase or decrease the 
volume. 

o Equalizer settings will allow you to adjust various frequency bands to tailor 
the sound to your liking. 

3. Fine-Tuning: 
o You can use advanced audio effects like the Compressor to modify dynamics 

by adjusting threshold, ratio, and other parameters. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



 

Chapter 6: Text and Titles 
Adding text and titles is an essential part of many video projects. Whether you are creating 
intros, lower-thirds, captions, or subtitles, Video Editing Pro has powerful tools to help you 
integrate text seamlessly into your video. This chapter covers how to add text and create 
customized titles. 

 

6.1 Adding Text 

Adding text to a video can be done through the Text filter, which offers customization options 
such as font, size, color, and position. 

Steps to Add Text: 

1. Select the Clip: Click on the clip in the timeline where you want to add text. 
2. Apply the Text Filter: 

o Open the Filters Panel and click the + button. 
o Search for Text and select Text: Simple or Text: HTML (the latter offers 

more advanced customization options). 
3. Text Properties: 

o Text Box: After adding the filter, type the text you want to display in the text 
box. 

o Font, Size, and Color: You can customize the font, size, and color of the text 
using the available options in the Properties Panel. 

o Positioning: Use the Position property to place the text on the screen. You can 
adjust the X and Y values for precise placement. 

4. Preview the Text: 
o Play the video in the Preview Window to see how the text looks with the 

video. Adjust the size, font, and color as necessary. 

 
 

Common Title Styles and Ideas: 

 Lower Thirds: A lower third title is typically used to introduce a person or show a 
subtitle. For a lower third, you can use a solid-colored rectangle at the bottom of the 
screen with text overlaid on top. 

 End Titles: For end credits or closing titles, you can create a scrolling text effect by 
using the Transform filter and animating the Position property. 

 Intro Titles: For intro titles, try using large, bold fonts with dynamic animations, such 
as a fade-in or slide-in effect. 

 Text Overlays: You can also use text to annotate parts of your video or add emphasis 
to specific moments. Keep the text simple and unobtrusive. 

 



 

Chapter 7: Editing Audio 
Audio is a vital element of any video project. Proper audio editing can make the difference 
between an average and a professional-quality video. Video Editing Pro provides robust audio 
editing features that allow you to adjust levels, apply audio effects, and add background 
music. This chapter will guide you through the process of editing audio within Video Editing 
Pro, ensuring your sound is as polished as your visuals. 

 

7.1 Adjusting Audio Levels 

Adjusting audio levels ensures that your sound is clear, balanced, and consistent throughout 
the video. Whether you're working with multiple audio tracks or a single voiceover, the ability 
to control audio levels is essential to prevent distortion or inaudible sections. 

Steps to Adjust Audio Levels: 

1. Select the Audio Track: 
o In the Timeline, click on the audio track (or video track with embedded audio) 

you wish to adjust. Video Editing Pro allows you to adjust levels for both 
separate audio tracks and audio embedded in video clips. 

2. Open the Filters Panel: 
o Go to View > Filters to open the Filters Panel (if it's not already visible). 

3. Add the Gain/Volume Filter: 
o In the Filters Panel, click the + button to add a new filter. 
o Choose Gain/Volume from the list of available audio filters. 

4. Adjust the Volume: 
o Once the filter is applied, you will see a Volume slider in the Properties 

Panel. Use this slider to increase or decrease the volume of the selected audio 
track. 

o You can adjust the gain by: 
 Moving the Slider: Slide it left to decrease the volume or right to 

increase it. 
 Typing a Value: You can also manually input a specific dB value for 

precise control. 
5. Monitor the Audio Levels: 

o As you adjust the volume, keep an eye on the audio meter in the Preview 
Window to avoid clipping (when the audio level becomes too high and 
distorts). Ensure the audio levels stay within the ideal range (usually -6dB to -
3dB). 

 

 

 



6. Using Keyframes for Dynamic Audio Levels: 
o If you need to adjust the audio levels over time (for example, fading the audio 

in or out), you can use keyframes. 
o To add keyframes: 

 In the Properties Panel for the Gain/Volume filter, click the 
Keyframe button (next to the volume slider). 

 Move the playhead to the point where you want the volume to change 
and adjust the volume. This will automatically add a keyframe. 

 Repeat the process at other points in the timeline to create a smooth 
fade-in or fade-out effect. 

7. Preview and Fine-Tune: 
o Play the timeline to hear how the adjusted audio sounds in context. Make any 

necessary adjustments to the levels to ensure a smooth, balanced mix. 

 

7.2 Using Audio Effects 

Audio effects allow you to shape your sound to suit the mood, correct issues, or enhance the 
listening experience. Video Editing Pro provides several audio effects, including equalization, 
compression, and noise reduction, to help you fine-tune your audio. 

Applying Audio Effects: 

1. Select the Audio Clip: 
o Click on the audio track in the Timeline that you wish to modify. 

2. Open the Filters Panel: 
o Go to View > Filters to open the Filters Panel (if not already open). 

3. Add an Audio Effect: 
o Click the + button to add a new filter. 
o Choose from a variety of audio filters, such as: 

 Equalizer: Adjust the frequency balance of your audio. You can boost 
or cut bass, midrange, and treble frequencies to enhance the sound 
quality. 

 Compressor: Use this effect to control the dynamic range of your 
audio. A compressor reduces the difference between the loudest and 
softest parts of the audio, making the sound more consistent. 

 High Pass/Low Pass Filter: These filters remove unwanted 
frequencies, like background hum (low pass) or wind noise (high pass). 

 Reverb: Add reverberation to simulate different environments (e.g., 
echo in a large hall or soft reverberation for a more atmospheric sound). 

 Noise Gate: Use this effect to reduce background noise by cutting out 
low-level sounds when they fall below a certain threshold. 

 

 

 

 



Common Audio Effects Explained: 

1. Equalizer: 
o The Equalizer filter allows you to adjust specific frequency ranges in the 

audio. You can either select a preset, like Rock or Pop, or adjust individual 
frequency sliders. 

o A typical equalizer has sliders for: 
 Low Frequencies: Bass sounds (e.g., kick drum, bass guitar). 
 Mid Frequencies: Vocals, instruments like guitar or piano. 
 High Frequencies: Treble sounds (e.g., cymbals, snare drum, and 

high-pitched instruments). 
o Boosting or cutting these frequencies can change the tone of the audio 

significantly, making it richer or clearer. 
2. Compressor: 

o A Compressor affects the dynamic range of the audio. When the audio 
exceeds a certain volume level (threshold), the compressor reduces its volume. 
This ensures that loud sounds don’t distort and that quieter sounds are still 
audible. 

o Threshold: The level at which the compressor starts working. 
o Ratio: The degree to which the loud sounds are reduced once they exceed the 

threshold. 
o Attack/Release: How quickly the compressor reacts to the sound and releases 

after compression. 
3. Reverb: 

o Adding Reverb creates a sense of space in your audio. For example, a short 
reverb might simulate a small room, while a long reverb might simulate a large 
hall. 

o Adjust parameters such as Room Size and Decay to control the effect’s 
intensity. 

4. Noise Gate: 
o The Noise Gate filter helps eliminate unwanted background noise. It works by 

allowing only sounds above a certain volume threshold to pass through. 
o Threshold: The volume level below which the audio is muted. 
o Attack/Release: Determines how quickly the noise gate opens and closes. 

5. High Pass/Low Pass Filter: 
o Use the High Pass Filter to remove low-frequency noise (e.g., hum, rumble), 

and the Low Pass Filter to remove high-frequency noise (e.g., hissing, high-
pitched buzzing). 

Fine-Tuning Audio Effects: 

 After applying an audio effect, listen to the output and fine-tune the settings to get the 
desired sound. 

 You can adjust the effect parameters by using the sliders or typing in specific values. 
 In the Filters Panel, you can enable or disable the effect by toggling the checkbox 

next to its name. 

 

 



 

7.3 Adding Background Music 

Background music is often used to enhance the mood or atmosphere of your video. Whether 
you are adding a cinematic score or background ambiance, Video Editing Pro provides an 
easy way to incorporate music into your project. 

Steps to Add Background Music: 

1. Import Your Audio File: 
o To add background music, you need to import an audio file (e.g., MP3, WAV). 
o Go to File > Open File and select the audio track you want to use. Video 

Editing Pro supports a wide range of audio formats, including MP3, WAV, 
OGG, and more. 

2. Add Music to the Timeline: 
o Drag the imported audio file from the Playlist or Project Files window to the 

Timeline. 
o Place the music on a separate audio track in the timeline. If you have existing 

voiceover or sound effects, ensure that the music track is positioned below 
those tracks to avoid overwriting them. 

3. Adjust the Music Volume: 
o Select the music track on the Timeline and go to the Filters Panel. 
o Add the Gain/Volume filter, and use the Volume slider to adjust the music 

volume to a comfortable level. You may want to lower the volume if it's too 
loud and overpowers the dialogue or sound effects in your video. 

4. Fade In and Fade Out: 
o Background music is often faded in at the beginning of a scene and faded out 

at the end. To add a fade effect: 
 Right-click the music track in the Timeline and select Fade In or Fade 

Out from the context menu. 
 You can adjust the duration of the fade by dragging the fade handle in 

the timeline. 
5. Looping Music: 

o If you need the music to loop, right-click the audio clip in the Timeline and 
select Copy. Then, paste the music on the same or a new track to create a loop. 

6. Adjusting Music Timing: 
o If the background music does not match the length of your video, you can trim 

or extend it. 
o Click and drag the edges of the music clip in the Timeline to shorten or 

lengthen the duration. 
7. Balancing Music with Dialogue: 

o If you have dialogue or narration in your video, make sure the background 
music does not overpower the speech. 

o Use the Gain/Volume filter on the background music to 

 

 

 



 

Chapter 8: Exporting the Project 
Once you’ve finished editing your video in Video Editing Pro, the next step is to export it into 
a format suitable for sharing or further processing. Video Editing Pro provides a wide variety 
of export options, allowing you to choose the right format, resolution, and quality for your 
final project. This chapter will guide you through the export process, including the different 
export options available and how to export your video. 

 

8.1 Export Options 

Video Editing Pro offers a broad range of export settings to ensure your project is delivered in 
the best possible quality, whether it's for social media, broadcast, or professional video 
production. The export settings include options for video formats, resolution, codecs, and 
more. 

Overview of Export Settings: 

1. Export Tab: 
o To access the export options, click on the Export tab located at the top of the 

Video Editing Pro window. 
o The Export tab is where you define the format, resolution, and other settings 

for your final video. You will also see a preview of the export settings here. 
2. Preset Options: 

Video Editing Pro provides several export presets for various purposes. These presets 
are pre-configured settings that are optimized for specific devices or platforms. Some 
common presets include: 

o YouTube: Optimized for uploading videos to YouTube, with options for 
different resolutions (e.g., 1080p, 4K). 

o Vimeo: Designed for uploading videos to Vimeo. 
o Instagram: Optimized for Instagram’s preferred video resolution and aspect 

ratio. 
o Web: Standard settings suitable for embedding videos on websites. 
o ProRes: A professional video format often used in film and broadcasting. 

To use a preset, simply select it from the Preset dropdown menu. This will 
automatically apply the corresponding settings for the selected platform. 

 

 

 

 

 



3. Video Format (Container): 
o In the Container dropdown menu, choose the video format that you want your 

project to be saved in. Common video containers include: 
 MP4: Popular format for online platforms (H.264 video codec, AAC 

audio codec). 
 MOV: Often used for high-quality videos and professional 

applications. 
 AVI: Older format, still useful for certain video editing workflows. 
 MKV: Great for high-quality video with multiple audio and subtitle 

tracks. 
o For most online sharing, MP4 is the most commonly used format because of 

its high compression and wide compatibility. 
4. Video Codec: 

o Video Editing Pro allows you to choose the video codec used for the export. 
The most common video codec is H.264, which offers a good balance between 
compression and video quality. 

o Other available codecs include HEVC (H.265), which provides higher 
compression efficiency at the cost of greater processing power, and ProRes for 
professional video workflows. 

5. Resolution and Aspect Ratio: 
o The Resolution setting lets you choose the output resolution of your video. 

Some common options are: 
 1920x1080 (Full HD): The standard for most YouTube and social 

media videos. 
 1280x720 (HD): Lower resolution, useful for faster uploads or smaller 

file sizes. 
 3840x2160 (4K): High-resolution video, ideal for cinematic content or 

when working with footage that requires high clarity. 
o Aspect Ratio: The default aspect ratio is 16:9, which is common for 

widescreen video. You can also choose other aspect ratios like 4:3, 21:9, or a 
custom ratio depending on your project’s needs. 

6. Frame Rate: 
o The Frame Rate dropdown allows you to select the number of frames per 

second (FPS) for your video. The most common frame rates are: 
 24 FPS: Standard frame rate for films. 
 30 FPS: Standard frame rate for online videos and television 

broadcasts. 
 60 FPS: Used for high-motion videos, such as gaming or sports 

footage. 
o You can also set a custom frame rate if needed. 

7. Audio Codec and Quality: 
o In the Audio tab, you can choose the audio codec for your video. The most 

common audio codec is AAC, which works well with most video containers. 
o You can also set the sample rate (e.g., 44100 Hz, 48000 Hz) and the bitrate 

(higher bitrate means better quality but larger file size). 

 

 

 



8. Advanced Settings: 
o If you require more advanced settings (e.g., for specific professional 

workflows), you can click the Advanced button. This gives you access to more 
detailed options such as B-frames, reference frames, and custom bitrate 
settings. 

Export Preset Recommendations: 

 For YouTube: Choose the YouTube preset, select the appropriate resolution (e.g., 
1080p or 4K), and leave other settings as is for a quick and optimized export. 

 For Social Media: Choose Instagram, Facebook, or Twitter presets for videos 
optimized for those platforms. You can also adjust the aspect ratio to match platform 
requirements (e.g., square videos for Instagram posts). 

 For Professional Use: If you're working on a professional project, use formats like 
ProRes or DNxHD for high-quality video outputs. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



 

8.2 Exporting Video 

Now that you have configured your export options, it’s time to begin the actual export 
process. This section will guide you through the process of rendering and saving your project 
into a finished video file. 

Steps to Export Your Video: 

1. Preview the Timeline: 
o Before exporting, make sure that your project in the Timeline is complete and 

ready to be exported. Check that all edits, filters, titles, and audio adjustments 
are finalized. 

2. Set the Export Range: 
o In the Timeline, you can select the specific section of your video you want to 

export by dragging the In/Out markers in the timeline. If you want to export 
the entire project, leave the markers at the beginning and end of the timeline. 

3. Click Export: 
o Once you’re satisfied with the settings, click the Export File button at the 

bottom of the Export tab. 
o A Save As dialog will appear, prompting you to choose a destination and 

filename for the exported video. 
4. Choose Export Location and File Name: 

o Choose a folder on your computer where you want the exported file to be 
saved. 

o Enter a name for the file and click Save. 
5. Begin Rendering: 

o Video Editing Pro will begin processing the video. The progress bar at the 
bottom of the screen will show you the export status. The time it takes to 
export will depend on the length of the video, the complexity of the edits, the 
resolution, and your system’s processing power. 

o You can continue working on other tasks in Video Editing Pro while 
exporting, but exporting may use up significant CPU and RAM resources, so 
it’s best to leave the computer idle during this process for faster rendering. 

6. Completion and Review: 
o Once the export is finished, you will see a notification that the export is 

complete. 
o Go to the folder where the video was saved and double-click to open the file. 

Review the video to ensure that everything exported correctly. 

Troubleshooting Export Issues: 

 Export Fails: If the export fails, try reducing the export settings (e.g., lower 
resolution, lower bitrate) to avoid overwhelming your system. 

 Audio/Video Sync Problems: If you notice that the audio and video are out of sync, 
try rendering with a different codec or check the timeline for any potential issues like 
overlapping clips. 

 Long Export Times: For longer videos, Video Editing Pro might take time to render 
the entire project. Make sure your computer has sufficient disk space and processing 
power. 



 

Chapter 9: Tips and Tricks 
In this chapter, we’ll provide useful tips and tricks to help you enhance your workflow in 
Video Editing Pro.

 

9.1 Keyboard Shortcuts 

Keyboard shortcuts are an essential part of any video editing software. They can significantly 
speed up your editing workflow, allowing you to execute common tasks without having to 
navigate through menus. Video Editing Pro provides a wide range of keyboard shortcuts that 
help with everything from basic editing to applying filters. 

Common Keyboard Shortcuts: 

 General Editing: 
o Ctrl + N: New project 
o Ctrl + O: Open project 
o Ctrl + S: Save project 
o Ctrl + Z: Undo 
o Ctrl + Shift + Z: Redo 
o Ctrl + X: Cut selected clip 
o Ctrl + C: Copy selected clip 
o Ctrl + V: Paste clip 
o Ctrl + D: Duplicate selected clip 

 Timeline Navigation: 
o Spacebar: Play/Pause 
o Arrow Left: Move one frame backward 
o Arrow Right: Move one frame forward 
o Shift + Arrow Left: Move to the previous clip 
o Shift + Arrow Right: Move to the next clip 
o Home: Move to the beginning of the timeline 
o End: Move to the end of the timeline 
o J: Fast rewind 
o L: Fast forward 

 Clip Editing: 
o S: Split the selected clip at the playhead 
o Ctrl + Shift + T: Trim the selected clip 
o Ctrl + Shift + M: Mute selected clip 
o Ctrl + A: Select all clips in the timeline 

 Filter and Effect Management: 
o Ctrl + F: Open Filters panel 
o Ctrl + Shift + F: Add a new filter 
o Delete: Remove selected filter or clip 

 Audio Editing: 
o Alt + A: Open the audio settings 
o Ctrl + Shift + G: Adjust the audio gain 
o Shift + Up Arrow: Increase audio track volume 
o Shift + Down Arrow: Decrease audio track volume 



Customizing Keyboard Shortcuts: 

Video Editing Pro allows you to customize keyboard shortcuts according to your preferences. 
To do so: 

1. Navigate to Settings > Keyboard Shortcuts. 
2. From here, you can search for specific actions and assign your own custom shortcuts. 
3. Save your changes and start using your personalized shortcuts. 

By using these shortcuts regularly, you’ll dramatically speed up your editing process and 
improve your overall efficiency. 

 

9.2 Common Issues and Solutions 

While Video Editing Pro is a powerful and reliable tool, you may occasionally encounter 
issues during your video editing workflow. This section provides solutions to some common 
problems users face, helping you troubleshoot and resolve issues quickly. 

1. Video Editing Pro Won’t Launch or Crashes Upon Startup 

Solution: 

 Ensure your computer meets the minimum system requirements for running Video 
Editing Pro. You can find these requirements on the Video Editing Pro website. 

 Update your graphics card drivers to the latest version, as Video Editing Pro relies 
heavily on the GPU for video rendering. 

 Try launching Video Editing Pro in Safe Mode by holding down Shift while starting 
the program. This will disable any custom settings, filters, or plugins that may be 
causing the issue. 

2. Video or Audio Is Out of Sync 

Solution: 

 Check the timeline for any accidental clips that might be overlapping or improperly 
aligned. 

 If you’ve used effects or filters that affect playback speed, such as time remapping or 
frame blending, try disabling them to see if the issue resolves. 

 Re-render the video by adjusting the export settings or codec. Some codecs might 
cause audio/video sync problems, so experimenting with different settings could fix 
the issue. 

 

 

 

 



3. Project Won’t Export or Export Takes Too Long 

Solution: 

 Make sure your export settings are correct, particularly the video resolution and 
bitrate. If your settings are too high, the export could take a very long time or even 
fail. 

 Try using a lower resolution or bitrate and exporting the video in smaller sections if 
you’re experiencing long render times. 

 Ensure you have enough available disk space for the exported file. If the destination 
disk is nearly full, Video Editing Pro might not be able to complete the export. 

4. Filters Aren’t Applied Properly 

Solution: 

 Double-check that you’ve selected the correct clip in the timeline and that the filter is 
applied to the intended clip. 

 Some filters, such as Chroma Key, may require specific conditions, such as proper 
color range settings. Make sure you’ve configured the filter settings properly. 

 If the filter still doesn’t appear to work correctly, try disabling other filters one by one 
to see if there’s a conflict. 

5. Video Editing Pro Performance Is Slow or Lagging 

Solution: 

 Video Editing Pro requires a decent amount of CPU and RAM to handle video editing, 
especially with high-resolution footage. Close any unnecessary programs to free up 
resources. 

 Enable proxy editing (Settings > Proxy). This feature allows you to work with lower-
quality versions of the video clips, making the editing process faster. Once editing is 
complete, Video Editing Pro will automatically switch back to the high-quality files 
for export. 

 If you’re working with large files or high-resolution footage, consider reducing the 
preview quality in the Preview Window to improve performance while editing. 

6. Missing or Corrupted Media Files 

Solution: 

 If you see the “Missing File” icon in the timeline, it means that Video Editing Pro 
cannot locate the source file. Ensure that the file has not been moved or renamed. 

 If you’ve moved your media files, use File > Open Recent to locate the project and 
re-link the missing media. Video Editing Pro will prompt you to locate the missing 
files manually. 

 Always make sure that your project and media files are stored in a stable location on 
your computer and back them up regularly to avoid losing data. 

 



 

Chapter 10: Resources and Support 

 

10.1 Official Documentation 

The official Video Editing Pro documentation is the primary resource for learning about the 
software’s features, settings, and troubleshooting methods. The documentation is regularly 
updated and provides detailed information on all aspects of the program. 

 Offizielle Webseite:  

https://magnussoft.net/Video-Editing-Pro 

 Tutorials:  

https://magnussoft.net/Video-Editing-Pro/magnussoft-Video-Editing-Pro-Tutorials 

 Manuals, etc.:  

https://magnussoft.net/Video‐Editing‐Pro/magnussoft‐Video‐Editing‐Pro‐Manual 


